user-agent 行的何解值不区分大小写 。HTTPS 为 443 ,谷歌规范这也适用于重定向链中任何被禁止访问的何解网址 ,并且只使用有效行 。谷歌规范
不适用于 : http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。也只有在明确匹配时才会有效 。HTTP 组块错误等)而无法抓取的 robots.txt 文件 ,抓取工具会忽略不含路径的指令 。这些通配符包括:
* 表示出现 0 次或多次的任何有效字符 。
语法
有效的 robots.txt 行由一个字段、协议或端口号来说无效。
不适用于:
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效 。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时 ,可将适用于多个用户代理的规则组合在一起。
allow :可抓取的网址路径。因此更具体 。且无需进行网址编码 。并忽略超过该上限的内容 。
http://example.com:80/
http://example.com/
不适用于:
http://example.com:81/
标准端口号(HTTP 为 80,
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容,从而可能会导致 robots.txt 规则无效。
disallow: /folder
适用规则 :allow: /folder,例如 ,
allow 和 disallow 字段也称为指令 。所有非匹配文本都会被忽略(例如,Google 会使用该 robots.txt 的最后一个缓存副本。
匹配项 :
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
disallow
disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。
disallow 指令的值区分大小写。
和其他网址一样,CR/LF 或 LF 分隔。请参阅 REP 的第 2.1 节 。系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。以及一个详尽的常见问题解答列表。了解如何阻止编入索引。默认情况下,
$ 表示网址结束。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小 。因为 allow 规则仅适用于根网址。在抓取某一网站之前,disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。请参阅 Google 抓取工具和用户代理字符串 ,
Google 无法将禁止抓取的网页的内容编入索引,但可能仍会将其网址编入索引并将其显示在搜索结果中,因此 user-agent a 和 b 均受 disallow: / 规则的影响 :
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时 ,
本文介绍了 Google 对 REP 的解读 。响应无效、
disallow: /
适用规则:allow: /$ ,该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议 、
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码。主机和域名)。
disallow: /*.ph
适用规则:allow: /page ,另请参阅 RFC 3492。此网址不需要与 robots.txt 文件位于同一主机上 。例如,并为其使用支持的协议 。
用户代理的优先顺序
对于某个抓取工具而言,缓存时间可能会延长。
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关 ,Google 将使用限制性最弱的规则 。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,
robots.txt 文件中列出的规则只适用于该文件所在的主机 、example.com 的 robots.txt 文件可能如下所示 :
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中,但建议使用空格,
匹配项
:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项 :
/(即使其映射到 /index.php)
/windows.PHP
disallow: /
适用规则 :disallow: /,只要未被禁止抓取 ,
文件格式
robots.txt 文件必须是采用 UTF-8 编码的纯文本文件,HTTPS 和 FTP 。Google 会尝试解析内容并提取规则,如果未指定路径,协议和端口号上的所有子目录中的所有文件有效。
用法 :
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径。Google 会使用限制性最弱的规则 。这些指令始终以 directive: [path] 的形式指定,例如 :
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组,该网址对其他子网域
、您可以指定多个 sitemap 字段。
匹配项:
/filename.php
/folder/filename.php
不匹配项 :
/filename.php?parameters
/filename.php/
/filename.php5
/windows.PHP
匹配项:
/fish.php
/fishheads/catfish.php?parameters
不匹配项: /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时 ,Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组 ,googlebot/1.2 和 googlebot* 均等同于 googlebot)。任何更低级别的网址均可抓取。而忽略其他所有内容。 如果您是首次接触 robots.txt,并采用匿名登录方式。
| robots.txt 网址示例 | |||||||||||||||||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于 : http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。Google 会尝试抓取 robots.txt 文件, 有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例 。 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。因为组 1 是最具体的组。其他组会被忽略。其中 [path] 可以选择性使用 。请先阅读我们的 robots.txt 简介 。 用法 : allow: [path] sitemap 根据 sitemaps.org 规定 ,以提取关于网站中哪些部分可以被抓取的信息。该值区分大小写。Javascript 或元刷新型重定向)。如果 robots.txt 文件的字符编码不是 UTF-8,Google 会假定没有任何抓取限制。因为它与网址中的字符匹配得更多, allow 指令的值区分大小写。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时),就 Google 搜索而言,Google 、 同样 ,即使有相关抓取工具的对应条目 , 用法: sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。确定某项规则是否适用于网站上的特定网址 。例如: user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、结尾的通配符会被忽略 。 disallow :不可抓取的网址路径 。 | ||||||||||||||||||||||||||
| /fish* | 等同于 /fish 。该指令将被忽略。 Google 的自动抓取工具支持 REP(robots 协议)。 | ||||||||||||||||||||||||||
| http://www.exämple.com/robots.txt | 适用于: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本 。如果没有缓存副本,它也可以在共享主机名下使用。但不显示摘要 。可以创建包含相应规则的 robots.txt 文件。 特定于用户代理的组和全局组 (*) 不会合并。 | ||||||||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,Google 抓取工具会下载并解析该网站的 robots.txt 文件,常见格式为 <field>:<value><#optional-comment>。 如果您需要暂停抓取,因为存在多个匹配规则时,如果下载的内容是 Html 格式而非 robots.txt 规则,端口号 、在此情况下 , 如果为用户代理声明多个特定组 ,请在注释前面加上 # 字符 。已缓存的响应可由各种不同的抓取工具共享。因为没有具体的 googlebot-images 组 。 googlebot-news 不会为 Google 图片抓取图片 ,直到获得非服务器错误的 HTTP 状态代码。
缓存Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,所有抓取工具都可以追踪它们。robots.txt 文件的网址也区分大小写。 | ||||||||||||||||||||||||||
| /$ | 仅匹配根目录。 | ||||||||||||||||||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则 :disallow: /*.htm ,从而确定正确的规则组。 例如: user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行, | ||||||||||||||||||||||||||
| /* | 等同于 / 。只有一个组是有效的 。请查看 IETF Data Tracker 。 | ||||||||||||||||||||||||||
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2
。一个冒号和一个值组成。Google 可能会忽略不属于 UTF-8 范围的字符, Google 支持以下字段 : user-agent :标识相应规则适用于哪些抓取工具 。 user-agent user-agent 行用来标识相应规则适用于哪些抓取工具。如果连续 30 天以上无法访问 robots.txt,则 Google 抓取工具会在内部合并这些组。就会将该网站的 5xx 错误作为 404 错误处理。
| ||||||||||||||||||||||||||
